hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Subru Krishnan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5391) FederationPolicy implementations (tieing together RouterFederationPolicy and AMRMProxyFederationPolicy)
Date Fri, 28 Oct 2016 22:20:58 GMT

    [ https://issues.apache.org/jira/browse/YARN-5391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15616770#comment-15616770

Subru Krishnan commented on YARN-5391:

Thanks [~curino] for the updated patch. It looks good, have a few minor comments below:

  * We should log exceptions before throwing in {{BasePolicyManager}}. Also, does it make
more sense to simply return the old instance instead?
  * I don't understand why the _get/setRouter/AMRMFederationPolicy()_ are public in {{BasePolicyManager}}?
If that's intentional, shouldn't they be in {{FederationPolicyManager}} interface?
  * The policy context is being validated in both {{BasePolicyManager::getAMRMPolicy}} and
  * We should rename *Base** classes to *Abstract**.
  * Suggestion: might be easier if {{ProbabilisticMulticastPolicyManager}} is renamed to {{WeightedMulticastPolicyManager}}
  * Why do we have _get/setWeightedPolicyInfo_ methods as public as they are specific to the
particular {{ProbabilisticMulticastPolicyManager}} implementation?

There are few checkstyle warnings which I feel can be fixed.

> FederationPolicy implementations (tieing together RouterFederationPolicy and AMRMProxyFederationPolicy)
> -------------------------------------------------------------------------------------------------------
>                 Key: YARN-5391
>                 URL: https://issues.apache.org/jira/browse/YARN-5391
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager, resourcemanager
>    Affects Versions: YARN-2915
>            Reporter: Carlo Curino
>            Assignee: Carlo Curino
>              Labels: oct16-hard
>         Attachments: YARN-5391-YARN-2915.04.patch, YARN-5391-YARN-2915.05.patch, YARN-5391-YARN-2915.06.patch,
YARN-5391.01.patch, YARN-5391.02.patch, YARN-5391.03.patch

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message