hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun Suresh (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (YARN-5620) Core changes in NodeManager to support for upgrade and rollback of Containers
Date Wed, 07 Sep 2016 22:43:21 GMT

    [ https://issues.apache.org/jira/browse/YARN-5620?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15472021#comment-15472021
] 

Arun Suresh edited comment on YARN-5620 at 9/7/16 10:42 PM:
------------------------------------------------------------

[~leftnoteasy], I feel that YARN-5221 and this are orthogonal.

YARN-5221 deals with the update of a _container allocation_, properties of the container that
are of interest to the Scheduler for allocation of the resource request like Resource size,
and ExecutionType.

This JIRA is pertaining to upgrade/rollback of the of the _container Process_, which are of
interest only to the NM for the running of the container, which are encapsulated in the *ContainerLaunchContext*
and Resources that need to be localized.

With regard to the AM-NM protocol, I feel we should keep both different.
# One for updating the container allocation which is handled by YARN-5221. Maybe we should
rename those to *updateContainerAllocation* rather than just *updateContainer* ?
# One for updating the container process, which this JIRA proposes to call *upgrade* and *rollback*




was (Author: asuresh):
[~leftnoteasy], I feel the YARN-5221 and this are orthogonal.

YARN-5221 deals with the update of a _container allocation_, properties of the container that
are of interest to the Scheduler for allocation of the resource request like Resource size,
and ExecutionType.

This JIRA is pertaining to upgrade/rollback of the of the _container Process_, which are of
interest only to the NM for the running of the container, which are encapsulated in the *ContainerLaunchContext*
and Resources that need to be localized.

With regard to the AM-NM protocol, I feel we should keep both different.
# One for updating the container allocation which is handled by YARN-5221. Maybe we should
rename those to *updateContainerAllocation* rather than just *updateContainer* ?
# One for updating the container process, which this JIRA proposes to call *upgrade* and *rollback*



> Core changes in NodeManager to support for upgrade and rollback of Containers
> -----------------------------------------------------------------------------
>
>                 Key: YARN-5620
>                 URL: https://issues.apache.org/jira/browse/YARN-5620
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Arun Suresh
>            Assignee: Arun Suresh
>         Attachments: YARN-5620.001.patch, YARN-5620.002.patch, YARN-5620.003.patch
>
>
> JIRA proposes to modify the ContainerManager (and other core classes) to support upgrade
of a running container with a new {{ContainerLaunchContext}} as well as the ability to rollback
the upgrade if the container is not able to restart using the new launch Context. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message