hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sunil G (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5607) Document TestContainerResourceUsage#waitForContainerCompletion
Date Wed, 31 Aug 2016 17:52:21 GMT

    [ https://issues.apache.org/jira/browse/YARN-5607?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15452882#comment-15452882

Sunil G commented on YARN-5607:

Yes, a common util class for all Mock** classes will be better. waitFor**** could be moved
there. I can try help here if we have common consensus to this approach. Thoughts?

> Document TestContainerResourceUsage#waitForContainerCompletion
> --------------------------------------------------------------
>                 Key: YARN-5607
>                 URL: https://issues.apache.org/jira/browse/YARN-5607
>             Project: Hadoop YARN
>          Issue Type: Test
>          Components: resourcemanager, test
>    Affects Versions: 2.9.0
>            Reporter: Karthik Kambatla
>              Labels: newbie
> The logic in TestContainerResourceUsage#waitForContainerCompletion (introduced in YARN-5024)
is not immediately obvious. It could use some documentation. Also, this seems like a useful
helper method. Should this be moved to one of the mock classes or to a util class? 

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message