hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Templeton (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-5388) MAPREDUCE-6719 requires changes to DockerContainerExecutor
Date Sun, 28 Aug 2016 17:12:21 GMT

     [ https://issues.apache.org/jira/browse/YARN-5388?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Daniel Templeton updated YARN-5388:
-----------------------------------
    Attachment: YARN-5388.branch-2.001.patch

Here's a patch for branch 2 that deprecates {{DockerContainerExecutor}} and fixes what I broke.

> MAPREDUCE-6719 requires changes to DockerContainerExecutor
> ----------------------------------------------------------
>
>                 Key: YARN-5388
>                 URL: https://issues.apache.org/jira/browse/YARN-5388
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: nodemanager
>            Reporter: Daniel Templeton
>            Assignee: Daniel Templeton
>            Priority: Critical
>             Fix For: 2.9.0
>
>         Attachments: YARN-5388.branch-2.001.patch
>
>
> Because the {{DockerContainerExecuter}} overrides the {{writeLaunchEnv()}} method, it
must also have the wildcard processing logic from YARN-4958/YARN-5373 added to it.  Without
it, the use of -libjars will fail unless wildcarding is disabled.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message