hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (YARN-3664) Federation PolicyStore internal APIs
Date Wed, 03 Aug 2016 22:15:20 GMT

    [ https://issues.apache.org/jira/browse/YARN-3664?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15406711#comment-15406711

Wangda Tan edited comment on YARN-3664 at 8/3/16 10:14 PM:


One minor comment:

Can we change getType of SubClusterPolicyConfiguration from String to enum. Using enum should
be much better for readability if the type comes from limited choices. And this could also
avoid potential bugs.

was (Author: leftnoteasy):

One minor comment:

Can we change getType of 

> Federation PolicyStore internal APIs
> ------------------------------------
>                 Key: YARN-3664
>                 URL: https://issues.apache.org/jira/browse/YARN-3664
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager, resourcemanager
>            Reporter: Subru Krishnan
>            Assignee: Subru Krishnan
>         Attachments: YARN-3664-YARN-2915-v0.patch, YARN-3664-YARN-2915-v1.patch, YARN-3664-YARN-2915-v2.patch,
> The federation Policy Store contains information about the capacity allocations made
by users, their mapping to sub-clusters and the policies that each of the components (Router,
AMRMPRoxy, RMs) should enforce

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message