hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Varun Vasudev (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5443) Add support for docker inspect
Date Fri, 29 Jul 2016 06:17:20 GMT

    [ https://issues.apache.org/jira/browse/YARN-5443?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15398782#comment-15398782

Varun Vasudev commented on YARN-5443:

Thanks for the patch [~shanekumpf@gmail.com]. Couple of changes -
+  public static final String EXITED_STATUS = "exited";
+  public static final String RUNNING_STATUS = "running";

No need for these - they're not being used anywhere.

Please rename DockerInspectCommandTest to TestDockerInspectCommand.

Also, I've noticed that DockerStopCommandTest has been committed to the code base. That needs
to be re-named to TestDockerStopCommand as well.

> Add support for docker inspect
> ------------------------------
>                 Key: YARN-5443
>                 URL: https://issues.apache.org/jira/browse/YARN-5443
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: yarn
>            Reporter: Shane Kumpf
>            Assignee: Shane Kumpf
>         Attachments: YARN-5443.001.patch
> Similar to the DockerStopCommand and DockerRunCommand, it would be desirable to have
a DockerInspectCommand. The initial use is for retrieving a containers status, but many other
uses are possible (IP information, volume information, etc).

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message