hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Varun Vasudev (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5307) Federation Application State APIs
Date Thu, 21 Jul 2016 09:18:20 GMT

    [ https://issues.apache.org/jira/browse/YARN-5307?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15387417#comment-15387417

Varun Vasudev commented on YARN-5307:

Thanks for the patch [~subru]! My thoughts -

+  public FederationInsertNewApplicationResponse insertNewApplication(
+      FederationInsertNewApplicationRequest request) throws YarnException; 
Rename insertNewApplication to addApplication

+  public FederationApplicationInfo getApplicationInfo(ApplicationId appId)
+      throws YarnException;
Rename getApplicationInfo to getApplication
In addition, the function should return a GetApplicationResponse and accept GetApplicationRequest

+  public Map<ApplicationId, FederationApplicationInfo> getAllApplicationsInfo()
+      throws YarnException;
Rename getAllApplicationsInfo to getApplications. Like above, it should return a GetApplicationsResponse
and accept GetApplicationsRequest

+  @Override
+  public int hashCode() {
+    return getApplicationId().hashCode();
+  }
In FederationApplicationInfo the hashCode function should take into account the same params
as the equals function.

> Federation Application State APIs
> ---------------------------------
>                 Key: YARN-5307
>                 URL: https://issues.apache.org/jira/browse/YARN-5307
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager, resourcemanager
>            Reporter: Subru Krishnan
>            Assignee: Subru Krishnan
>         Attachments: YARN-5307-YARN-2915-v1.patch, YARN-5307-YARN-2915-v2.patch
> The Federation Application State encapsulates the mapping between an application and
it's _home_ sub-cluster, i.e. the sub-cluster to which it is submitted to by the Router. Please
refer to the design doc in parent JIRA for further details.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message