hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5191) Rename the “download=true” option for getLogs in NMWebServices and AHSWebServices
Date Sun, 05 Jun 2016 05:20:59 GMT

    [ https://issues.apache.org/jira/browse/YARN-5191?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15315740#comment-15315740

Vinod Kumar Vavilapalli commented on YARN-5191:

[~xgong], couple of more comments:
 - Add a test to validate the default format behavior.
 - Refactor the common code for handling of format / contentType between AHSWebServices and
NMWebServices - getting default format value, validation for invalid contentType etc.
 - Rename the new *ContentType methods in WebAppUtil to explicitly say *LogContentType.
 - What's the purpose for "X-Content-Type-Options" ? Can you add code-comments?

> Rename the “download=true” option for getLogs in NMWebServices and AHSWebServices
> ---------------------------------------------------------------------------------
>                 Key: YARN-5191
>                 URL: https://issues.apache.org/jira/browse/YARN-5191
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Xuan Gong
>            Assignee: Xuan Gong
>         Attachments: YARN-5191.1.patch, YARN-5191.2.patch, YARN-5191.3.patch, YARN-5191.4.patch
> Rename the “download=true” option to instead be something like “format=octet-stream”,
so that we are explicit

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message