hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Varun Saxena (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5191) Rename the “download=true” option for getLogs in NMWebServices and AHSWebServices
Date Sat, 04 Jun 2016 12:42:59 GMT

    [ https://issues.apache.org/jira/browse/YARN-5191?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15315485#comment-15315485
] 

Varun Saxena commented on YARN-5191:
------------------------------------

Was looking at the code added with regards to log tooling enhancement. Found that we haven't
closed LogReader in AHSWebServices#getStreamingOutput.
This would lead to connections with datanode stuck in CLOSE_WAIT state and may eventually
lead to too many open files error.
I think this needs to be fixed.
This issue is not directly related to this JIRA but to code added in one of JIRA in parent.
As this was one of the related ongoing JIRA, just commented here to bring attention to the
issue so that it can be handled, maybe in this JIRA itself ?

Moreover, in NMWebServices#getLogs we do not close FileInputStream. This is not a very big
issue as FileInputStream has finalize method which would close the input stream. But this
would mean that the corresponding FDs' will be hanging around till next cycle of GC happens.
This can be fixed as well although this seems to be a very old issue.

> Rename the “download=true” option for getLogs in NMWebServices and AHSWebServices
> ---------------------------------------------------------------------------------
>
>                 Key: YARN-5191
>                 URL: https://issues.apache.org/jira/browse/YARN-5191
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Xuan Gong
>            Assignee: Xuan Gong
>         Attachments: YARN-5191.1.patch, YARN-5191.2.patch, YARN-5191.3.patch, YARN-5191.4.patch
>
>
> Rename the “download=true” option to instead be something like “format=octet-stream”,
so that we are explicit



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message