hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joep Rottinghuis (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5070) upgrade HBase version for first merge
Date Thu, 09 Jun 2016 05:13:21 GMT

    [ https://issues.apache.org/jira/browse/YARN-5070?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15321904#comment-15321904
] 

Joep Rottinghuis commented on YARN-5070:
----------------------------------------

It seems [~apurtell] introduced the Region interface instead of HRegion as part of HBASE-12972
[~jonathan.lawlor] introduced the ScannerContext in HBASE-13421 to encapsulate
the scanner limits and progress towards those limits. Perhaps he can give us a pointer as
to how to best deal with limits after HBase 1.1.

Looking at the changes made to adapt Phoenix copro's to the new Region interface it makes
me wonder if we should capture Throwables, add some region name info and propagate the exception.
We might want to consider catching InterruptedException during some of our longer running
operations and yield processing through something like:
{code}
   catch (InterruptedException ie) {
      throw new InterruptedException(context.getEnvironment().getRegion().getRegionNameAsString(),
ie);
   }
{code}

> upgrade HBase version for first merge
> -------------------------------------
>
>                 Key: YARN-5070
>                 URL: https://issues.apache.org/jira/browse/YARN-5070
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: timelineserver
>    Affects Versions: YARN-2928
>            Reporter: Sangjin Lee
>            Assignee: Vrushali C
>            Priority: Critical
>              Labels: yarn-2928-1st-milestone
>         Attachments: YARN-5070-YARN-2928.01.patch, YARN-5070-YARN-2928.02.patch
>
>
> Currently we set the HBase version for the timeline service storage to 1.0.1. This is
a fairly old version, and there are reasons to upgrade to a newer version. We should upgrade
it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message