hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vrushali C (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5070) upgrade HBase version for first merge
Date Wed, 08 Jun 2016 19:23:21 GMT

    [ https://issues.apache.org/jira/browse/YARN-5070?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15321287#comment-15321287
] 

Vrushali C commented on YARN-5070:
----------------------------------

I have been looking into hbase upgrade. Here is a summary:

Background:
ATS should make use of a table specific coprocessor for the Flow table (instead of system
coprocessors). 

Problems in reaching that goal:
Table specific coprocessor requires dynamic loading of coprocessors to work for classes starting
with org.apache.hadoop. Presently that is (fixed) allowed only in hbase 1.2.x.

Now, the version of phoenix that will work with hbase 1.2.x is still to be released (4.8.0).

Current options:
So now we have an option of upgrading to hbase 1.1.x. This version still does not allow for
dynamic loading but it will be just good to upgrade in general. 

So now with the latest stable release 1.1.5, there are several dependency convergence errors.

Presently, I got the code (with some stubbed methods added) to compile with HBase 1.1.3. 

Current in progress steps with 1.1.3:
- 1.1.3 has API changes for the coprocessor, specifically the introduction of ScannerContext.ScannerContext
instances encapsulate limit tracking AND progress towards those limits during invocations
of next.  But this class has package private fields and I am looking into reflection to get
those and update them. 

In short, this requires certain code changes at the level of the scan iterations which will
need adequate testing.





> upgrade HBase version for first merge
> -------------------------------------
>
>                 Key: YARN-5070
>                 URL: https://issues.apache.org/jira/browse/YARN-5070
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: timelineserver
>    Affects Versions: YARN-2928
>            Reporter: Sangjin Lee
>            Assignee: Vrushali C
>            Priority: Critical
>              Labels: yarn-2928-1st-milestone
>
> Currently we set the HBase version for the timeline service storage to 1.0.1. This is
a fairly old version, and there are reasons to upgrade to a newer version. We should upgrade
it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message