hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Varun Saxena (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5093) created time shows 0 in most REST output
Date Tue, 17 May 2016 21:59:14 GMT

    [ https://issues.apache.org/jira/browse/YARN-5093?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15287708#comment-15287708
] 

Varun Saxena commented on YARN-5093:
------------------------------------

[~sjlee0],
For flow activities we do not populate created time. The top of the day timestamp is carried
in INFO field (SYSTEM_INFO_DATE: 1463356800000). Because flow activity does not indicate flow
created time.
And while setting flow runs within flow activity, we do not set created time for these flow
runs either. Reason being RUN_ID column in flow activity table does not carry the min start
time info associated with a flow run.

Created time should appear in app and entity query though. Will check on that. Let me see
if this comes up for me.

> created time shows 0 in most REST output
> ----------------------------------------
>
>                 Key: YARN-5093
>                 URL: https://issues.apache.org/jira/browse/YARN-5093
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: timelineserver
>    Affects Versions: YARN-2928
>            Reporter: Sangjin Lee
>            Priority: Critical
>              Labels: yarn-2928-1st-milestone
>
> When querying the REST API, I find that the created time value is returned as "0" for
most of the output. It includes:
> - flow activity and flow runs in the flow activity page
> - apps in the application page
> - entities in the entity page
> For example, in the flow activity page,
> {noformat}
> {
> metrics: [ ],
> events: [ ],
> id: "yarn_cluster/1463356800000/sjlee@ds-date",
> type: "YARN_FLOW_ACTIVITY",
> createdtime: 0,
> flowruns: [
> {
> metrics: [ ],
> events: [ ],
> id: "sjlee@ds-date/1463435661428",
> type: "YARN_FLOW_RUN",
> createdtime: 0,
> info: {
> SYSTEM_INFO_FLOW_VERSION: "1",
> SYSTEM_INFO_FLOW_RUN_ID: 1463435661428,
> SYSTEM_INFO_FLOW_NAME: "ds-date",
> SYSTEM_INFO_USER: "sjlee"
> },
> isrelatedto: { },
> relatesto: { }
> }
> ],
> info: {
> SYSTEM_INFO_CLUSTER: "yarn_cluster",
> UID: "yarn_cluster!sjlee!ds-date",
> SYSTEM_INFO_FLOW_NAME: "ds-date",
> SYSTEM_INFO_DATE: 1463356800000,
> SYSTEM_INFO_USER: "sjlee"
> },
> isrelatedto: { },
> relatesto: { }
> }
> {noformat}
> The only page that appears to show the proper created time value is the flow run page.
I think the data exists in the storage but is not populated in the UI.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org


Mime
View raw message