hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Varun Vasudev (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-5088) Improve "yarn log" command-line to read the last K bytes for the log files
Date Tue, 31 May 2016 11:20:12 GMT

    [ https://issues.apache.org/jira/browse/YARN-5088?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15307581#comment-15307581

Varun Vasudev commented on YARN-5088:

Thanks for the patch [~xgong].
# Can you please address the findbug warnings as well as the checkstyle warnings in TestLogsCLI?
# In AggregatedLogFormat::readContainerLogs - rename actualRead to totalBytesToRead 
In AggregatedLogFormat::readContainerLogsForALogType - rename actualRead to totalBytesToRead

In AHSWebServices::StreamingOutput::write - rename actualRead to totalBytesToRead
In NMWebServices::StreamingOutput::write - rename actualRead to totalBytesToRead
It looks like there's a bunch of common code between readContainerLogs, readContainerLogsForALogType,
AHSWebServices::StreamingOutput::write, In NMWebServices::StreamingOutput::write - can we
re-factor the existing and clean it up?
# Add test cases where you read from the end but the bytes is greater than the log file size?

> Improve "yarn log" command-line to read the last K bytes for the log files
> --------------------------------------------------------------------------
>                 Key: YARN-5088
>                 URL: https://issues.apache.org/jira/browse/YARN-5088
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Xuan Gong
>            Assignee: Xuan Gong
>         Attachments: YARN-5088.1.patch, YARN-5088.2.patch, YARN-5088.3.patch, YARN-5088.4.patch

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org

View raw message