hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-4718) Rename variables in SchedulerNode to reduce ambiguity post YARN-1011
Date Fri, 25 Mar 2016 21:15:25 GMT

    [ https://issues.apache.org/jira/browse/YARN-4718?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15212432#comment-15212432
] 

Karthik Kambatla commented on YARN-4718:
----------------------------------------

That is indeed a valid concern, Junping. 

Changing the names of UI elements would be incompatible, but leaving the class field names
the same makes the code harder to understand. In the interest of avoiding errors, we thought
this was an acceptable tradeoff. 

> Rename variables in SchedulerNode to reduce ambiguity post YARN-1011
> --------------------------------------------------------------------
>
>                 Key: YARN-4718
>                 URL: https://issues.apache.org/jira/browse/YARN-4718
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: scheduler
>    Affects Versions: 2.8.0
>            Reporter: Karthik Kambatla
>            Assignee: Inigo Goiri
>             Fix For: 2.9.0
>
>         Attachments: YARN-4718-v000.patch, YARN-4718-v001.patch, YARN-4718-v002.patch,
YARN-4718-v003.patch, YARN-4718-v004.patch
>
>
> As discussed in YARN-1011, we are planning to add a few more variables regarding utilization
to SchedulerNode. To ensure the new variables are descriptive and don't lead to confusion,
the existing variables could use some renaming. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message