hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsuyoshi Ozawa (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-4648) Move preemption related tests from TestFairScheduler to TestFairSchedulerPreemption
Date Sun, 21 Feb 2016 01:49:18 GMT

    [ https://issues.apache.org/jira/browse/YARN-4648?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15155844#comment-15155844
] 

Tsuyoshi Ozawa commented on YARN-4648:
--------------------------------------

[~lewuathe] Thank you for updating. Unfortunatelly, startResourceManagerForPreemptionTest
is still confusing because the name of the class is TestFairSchedulerPreemption. 

My suggestion is to rename startResourceManager to startResourceManagerWithStubbedFairScheduler,
and startResourceManagerForPreemptionTest to startResourceManagerWithRealFairScheduler. Do
you have any better idea?

> Move preemption related tests from TestFairScheduler to TestFairSchedulerPreemption
> -----------------------------------------------------------------------------------
>
>                 Key: YARN-4648
>                 URL: https://issues.apache.org/jira/browse/YARN-4648
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: fairscheduler
>    Affects Versions: 2.8.0
>            Reporter: Karthik Kambatla
>            Assignee: Kai Sasaki
>              Labels: newbie++
>         Attachments: YARN-4648.01.patch, YARN-4648.02.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message