hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira AJISAKA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-4630) Remove useless boxing/unboxing code (Hadoop YARN)
Date Wed, 24 Feb 2016 14:51:18 GMT

    [ https://issues.apache.org/jira/browse/YARN-4630?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15163125#comment-15163125
] 

Akira AJISAKA commented on YARN-4630:
-------------------------------------

bq. can I check this since it seems to include the changes against ContainerId?
Okay.
{code:title=ContainerId.java}
   public int compareTo(ContainerId other) {
     if (this.getApplicationAttemptId().compareTo(
         other.getApplicationAttemptId()) == 0) {
-      return Long.valueOf(getContainerId())
-          .compareTo(Long.valueOf(other.getContainerId()));
+      return Long.compare(getContainerId(), other.getContainerId());
{code}
IMO, the change is safe since the following change is only to remove unnecessarily boxing/unboxing.

> Remove useless boxing/unboxing code (Hadoop YARN)
> -------------------------------------------------
>
>                 Key: YARN-4630
>                 URL: https://issues.apache.org/jira/browse/YARN-4630
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: yarn
>    Affects Versions: 3.0.0
>            Reporter: Kousuke Saruta
>            Priority: Minor
>         Attachments: YARN-4630.0.patch
>
>
> There are lots of places where useless boxing/unboxing occur.
> To avoid performance issue, let's remove them.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message