hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Naganarasimha G R (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-4654) Yarn node label CLI should parse "=" correctly when trying to remove all labels on a node
Date Fri, 29 Jan 2016 17:26:39 GMT

    [ https://issues.apache.org/jira/browse/YARN-4654?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15123829#comment-15123829
] 

Naganarasimha G R commented on YARN-4654:
-----------------------------------------

Test case failures are either not related to the modifications in the patch and timed out
ones are passing locally.
[~rohithsharma] can you take a look at this ?

> Yarn node label CLI should parse "=" correctly when trying to remove all labels on a
node
> -----------------------------------------------------------------------------------------
>
>                 Key: YARN-4654
>                 URL: https://issues.apache.org/jira/browse/YARN-4654
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Wangda Tan
>            Assignee: Naganarasimha G R
>         Attachments: YARN-4654.v1.001.patch, YARN-4654.v1.002.patch
>
>
> Currently, when adding labels to nodes, user can run:
> {{yarn rmadmin -replaceLabelsOnNode "host1=x host2=y"}}
> However, when removing labels from a node, user has to run:
> {{yarn rmadmin -replaceLabelsOnNode "host1 host2"}}
> Instead of:
> {{yarn rmadmin -replaceLabelsOnNode "host1= host2="}}
> We should handle both of "=" exists/not-exists case when removing labels on a node.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message