hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-4654) Yarn node label CLI should parse "=" correctly when trying to remove all labels on a node
Date Fri, 29 Jan 2016 02:16:39 GMT

    [ https://issues.apache.org/jira/browse/YARN-4654?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15122776#comment-15122776
] 

Wangda Tan commented on YARN-4654:
----------------------------------

[~Naganarasimha], 
Thanks! Please go ahead.

> Yarn node label CLI should parse "=" correctly when trying to remove all labels on a
node
> -----------------------------------------------------------------------------------------
>
>                 Key: YARN-4654
>                 URL: https://issues.apache.org/jira/browse/YARN-4654
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Wangda Tan
>            Assignee: Naganarasimha G R
>
> Currently, when adding labels to nodes, user can run:
> {{yarn rmadmin -replaceLabelsOnNode "host1=x host2=y"}}
> However, when removing labels from a node, user has to run:
> {{yarn rmadmin -replaceLabelsOnNode "host1 host2"}}
> Instead of:
> {{yarn rmadmin -replaceLabelsOnNode "host1= host2="}}
> We should handle both of "=" exists/not-exists case when removing labels on a node.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message