hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun Suresh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-4358) Improve relationship between SharingPolicy and ReservationAgent
Date Sat, 21 Nov 2015 18:41:11 GMT

    [ https://issues.apache.org/jira/browse/YARN-4358?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15020611#comment-15020611

Arun Suresh commented on YARN-4358:

Thanks for the patch [~curino]. The patch looks good generally. Few minor nits:

# minor formatting issue in testSharingPolicyFeedback (line 190)
# remove instances of SubtractionIsNegative. Also, in CapacityOverTimePolicy::availableResources,
as well as InMemoryPlan::getAvailableResources. you can completely remove the try catch.
# It would be nice if we could probably generalize RLESparceAllocation, currently it is being
used to count user reservations etc. We can probably circle back to this after YARN-3926
# in InMemoryReservationAllocation::compareTo, you can probably collapse both the if statements
to :
   {{return other.getReservationId().getId() - this.getReservationId().getId()}}
# maybe rename *getReservationCountForUser* to *getReservationCountForUserAtTime*

> Improve relationship between SharingPolicy and ReservationAgent
> ---------------------------------------------------------------
>                 Key: YARN-4358
>                 URL: https://issues.apache.org/jira/browse/YARN-4358
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler, fairscheduler, resourcemanager
>            Reporter: Carlo Curino
>            Assignee: Carlo Curino
>             Fix For: 2.8.0
>         Attachments: YARN-4358.patch
> At the moment an agent places based on available resources, but has no visibility to
extra constraints imposed by the SharingPolicy. While not all constraints are easily represented
some (e.g., max-instantaneous resources) are easily represented.

This message was sent by Atlassian JIRA

View raw message