hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Li Lu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-4234) New put APIs in TimelineClient for ats v1.5
Date Wed, 11 Nov 2015 22:14:11 GMT

    [ https://issues.apache.org/jira/browse/YARN-4234?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15001224#comment-15001224
] 

Li Lu commented on YARN-4234:
-----------------------------

Well let me clarify one thing: ATS v1.5 supports all ATS v1 features, while ATS v2 is not
compatible with ATS v1 and 1.5. Therefore, how about this:

timeline-service.version: 1 -> only ATS v1 features are supported. 
timeline-service.version: 1.5 -> supports ATS v1 and v1.5 features.
timeline-service.version: 2 -> only ATS v2 features are supported. 

This describes the feature set on the server side of ATS. The client can use this information
from server to perform sanity check. I agree with [~Naganarasimha] that checking this config
on the client side does not quite make sense, and clearly we need some mechanisms to let the
client know the current running version of ATS. However, I think this is orthogonal to the
config key proposed in YARN-4183 (and added here). 

> New put APIs in TimelineClient for ats v1.5
> -------------------------------------------
>
>                 Key: YARN-4234
>                 URL: https://issues.apache.org/jira/browse/YARN-4234
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: timelineserver
>            Reporter: Xuan Gong
>            Assignee: Xuan Gong
>         Attachments: YARN-4234.1.patch, YARN-4234.2.patch, YARN-4234.20151109.patch,
YARN-4234.20151110.1.patch, YARN-4234.20151111.1.patch, YARN-4234.3.patch
>
>
> In this ticket, we will add new put APIs in timelineClient to let clients/applications
have the option to use ATS v1.5



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message