hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Li Lu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-4200) Refactor reader classes in storage to nest under hbase specific package name
Date Mon, 12 Oct 2015 23:13:05 GMT

     [ https://issues.apache.org/jira/browse/YARN-4200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Li Lu updated YARN-4200:
    Attachment: YARN-4200-YARN-2928.001.patch

Since YARN-4075 is in and we're relatively stable on the reader implementation side (I assume),
I'd like to perform this clean up work quickly. Mainly two tasks in this refactoring JIRA:
- Group all hbase reader related classes in a subpackage in timelineservice.storage. I noticed
that all existing subpackages in storage are specially designed for hbase, so I'm using the
name "reader" to indicate all classes are reader related. In future if we want to have subpackages
for other storage implementations, we may need to create packages like storage.<storage_type>.<package_name>.

- Expose {{TimelineEntityReader}} and {{TimelineEntityReaderFactory}} classes to the outside
world. Ideally they should be the only interface classes to operate on our HBase reader design.

Please feel free to let me know if there are any concerns w.r.t this change. Or if there are
any ongoing work that we'd like to finish before this refactor goes in. Thanks! 

> Refactor reader classes in storage to nest under hbase specific package name
> ----------------------------------------------------------------------------
>                 Key: YARN-4200
>                 URL: https://issues.apache.org/jira/browse/YARN-4200
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: timelineserver
>            Reporter: Vrushali C
>            Assignee: Li Lu
>            Priority: Minor
>         Attachments: YARN-4200-YARN-2928.001.patch
> As suggested by [~gtCarrera9] in YARN-4074, filing jira to refactor the code to group
together the reader classes under a package in storage that indicates these are hbase specific.

This message was sent by Atlassian JIRA

View raw message