hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nijel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1948) Expose utility methods in Apps.java publically
Date Wed, 17 Jun 2015 13:53:01 GMT

    [ https://issues.apache.org/jira/browse/YARN-1948?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14589782#comment-14589782

nijel commented on YARN-1948:

thanks [~vinodkv] for the comment
I am thinking of changing both method names as "*updateEnv*". Not getting any better name
public static void updateEnv(

Another option is to leave the env related stuff and name it from map perspective since the
env is represented as map in this function.

Any thoughts ? 

> Expose utility methods in Apps.java publically
> ----------------------------------------------
>                 Key: YARN-1948
>                 URL: https://issues.apache.org/jira/browse/YARN-1948
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: api
>    Affects Versions: 2.4.0
>            Reporter: Sandy Ryza
>            Assignee: nijel
>              Labels: newbie
>         Attachments: YARN-1948-1.patch
> Apps.setEnvFromInputString and Apps.addToEnvironment are methods used by MapReduce, Spark,
and Tez that are currently marked private.  As these are useful for any YARN app that wants
to allow users to augment container environments, it would be helpful to make them public.
> It may make sense to put them in a new class with a better name.

This message was sent by Atlassian JIRA

View raw message