hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Naganarasimha G R (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-3600) AM container link is broken (on a killed application, at least)
Date Fri, 08 May 2015 10:16:02 GMT

     [ https://issues.apache.org/jira/browse/YARN-3600?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Naganarasimha G R updated YARN-3600:
------------------------------------
    Attachment: YARN-3600.20150508-1.patch

It was failing in both cases when app is completed or killed and also null was displayed when
AM container  is not launched. Uploading a patch with the correction. [~devaraj.k] can you
please take a look

> AM container link is broken (on a killed application, at least)
> ---------------------------------------------------------------
>
>                 Key: YARN-3600
>                 URL: https://issues.apache.org/jira/browse/YARN-3600
>             Project: Hadoop YARN
>          Issue Type: Bug
>    Affects Versions: 2.8.0
>            Reporter: Sergey Shelukhin
>            Assignee: Naganarasimha G R
>         Attachments: YARN-3600.20150508-1.patch
>
>
> Running some fairly recent (couple weeks ago) version of 2.8.0-SNAPSHOT. 
> I have an application that ran fine for a while and then I yarn kill-ed it. Now when
I go to the only app attempt URL (like so: http://(snip RM host name):8088/cluster/appattempt/appattempt_1429683757595_0795_000001)
> I see:
> AM Container: 	container_1429683757595_0795_01_000001
> Node: 	N/A 
> and the container link goes to {noformat}http://(snip RM host name):8088/cluster/N/A
> {noformat}
> which obviously doesn't work



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message