hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jian He (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-3546) AbstractYarnScheduler.getApplicationAttempt seems misleading, and there're some misuse of it
Date Thu, 30 Apr 2015 02:47:06 GMT

    [ https://issues.apache.org/jira/browse/YARN-3546?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14520742#comment-14520742

Jian He commented on YARN-3546:

Didn't get you. the waitForSchedulerAppAttemptAdded implementations should be correct, it
waits for the given attempt to be added into scheduler. In fact, after YARN-3533, this call
is not needed any more. so, it becomes a no-op. Regarding the name, it does't make too much
difference.. The implement is to return the corresponding attempt, given the attempt Id. And
the only way today to get that is through the corresponding application and from there get
the current attempt. 

> AbstractYarnScheduler.getApplicationAttempt seems misleading,  and there're some misuse
of it
> ---------------------------------------------------------------------------------------------
>                 Key: YARN-3546
>                 URL: https://issues.apache.org/jira/browse/YARN-3546
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: resourcemanager
>            Reporter: sandflee
> I'm not familiar with scheduler,  with first eyes, I thought this func returns the schdulerAppAttempt
info corresponding to appAttemptId, but actually it returns the current schdulerAppAttempt.
> It seems misled others too, such as
> TestWorkPreservingRMRestart.waitForNumContainersToRecover
> MockRM.waitForSchedulerAppAttemptAdded
> should I rename it to T getCurrentSchedulerApplicationAttempt(ApplicationId applicationid)
> or returns null  if current attempt id not equals to the request attempt id ?
> comment preferred!

This message was sent by Atlassian JIRA

View raw message