hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Varun Vasudev (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-3484) Fix up yarn top shell code
Date Wed, 29 Apr 2015 16:01:08 GMT

     [ https://issues.apache.org/jira/browse/YARN-3484?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Varun Vasudev updated YARN-3484:
--------------------------------
    Attachment: YARN-3484.002.patch

bq. variables that are local to a function should be declared local.
Fixed.

bq. avoid using mixed case as per the shell programming guidelines
Fixed.

bq. yarnTopArgs is effectively a global. It should either get renamed to YARN_foo or another
to not pollute the shell name space or another approach is process set_yarn_top_args as a
subshell, reading its input directly to avoid the global entirely
Fixed; renamed it to YARN_TOP_ARGS.

bq. set_yarn_top_args should be hadoop_ something so as to not pollute the shell name space
Fixed; changed the name to hadoop_set_yarn_top_args

> Fix up yarn top shell code
> --------------------------
>
>                 Key: YARN-3484
>                 URL: https://issues.apache.org/jira/browse/YARN-3484
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: scripts
>    Affects Versions: 3.0.0
>            Reporter: Allen Wittenauer
>            Assignee: Varun Vasudev
>         Attachments: YARN-3484.001.patch, YARN-3484.002.patch
>
>
> We need to do some work on yarn top's shell code.
> a) Just checking for TERM isn't good enough.  We really need to check the return on tput,
especially since the output will not be a number but an error string which will likely blow
up the java code in horrible ways.
> b) All the single bracket tests should be double brackets to force the bash built-in.
> c) I'd think I'd rather see the shell portion in a function since it's rather large.
 This will allow for args, etc, to get local'ized and clean up the case statement.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message