hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-3318) Create Initial OrderingPolicy Framework and FifoOrderingPolicy
Date Thu, 09 Apr 2015 23:06:13 GMT

    [ https://issues.apache.org/jira/browse/YARN-3318?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14488456#comment-14488456

Wangda Tan commented on YARN-3318:

Hi Craig,
Thanks for updating, the latest patch generally LGTM, several minor comments:
- Can you put some comments explain why CompoundComparator is needed here, since nobody is
using this class
- It's better to merge getSchedulingConsumption/getSchedulingDemand to getResourceUsage, and
returns {{ResourceUsage}} class, which contains by-label statistics. Or explicitly call it
- If you agree above, rename updateSchedulingState to updateResourceUsage/updateCachedResourceUsage?
- Add a getName to SchedulableEntity, this will be usaful when doing logging, etc.
- compareInputOrderTo and compareSubmissionOrderTo, which one is better in your mind?

> Create Initial OrderingPolicy Framework and FifoOrderingPolicy
> --------------------------------------------------------------
>                 Key: YARN-3318
>                 URL: https://issues.apache.org/jira/browse/YARN-3318
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: scheduler
>            Reporter: Craig Welch
>            Assignee: Craig Welch
>         Attachments: YARN-3318.13.patch, YARN-3318.14.patch, YARN-3318.17.patch, YARN-3318.34.patch,
YARN-3318.35.patch, YARN-3318.36.patch, YARN-3318.39.patch, YARN-3318.45.patch, YARN-3318.47.patch,
YARN-3318.48.patch, YARN-3318.52.patch
> Create the initial framework required for using OrderingPolicies and an initial FifoOrderingPolicy

This message was sent by Atlassian JIRA

View raw message