hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2123) Progress bars in Web UI always at 100% due to non-US locale
Date Fri, 24 Apr 2015 12:33:39 GMT

    [ https://issues.apache.org/jira/browse/YARN-2123?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14510957#comment-14510957
] 

Hadoop QA commented on YARN-2123:
---------------------------------

\\
\\
| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | pre-patch |  14m 38s | Pre-patch trunk compilation is healthy. |
| {color:green}+1{color} | @author |   0m  0s | The patch does not contain any @author tags.
|
| {color:red}-1{color} | tests included |   0m  0s | The patch doesn't appear to include any
new or modified tests.  Please justify why no new tests are needed for this patch. Also please
list what manual steps were performed to verify this patch. |
| {color:green}+1{color} | whitespace |   0m  0s | The patch has no lines that end in whitespace.
|
| {color:green}+1{color} | javac |   7m 33s | There were no new javac warning messages. |
| {color:green}+1{color} | javadoc |   9m 30s | There were no new javadoc warning messages.
|
| {color:green}+1{color} | release audit |   0m 23s | The applied patch does not increase
the total number of release audit warnings. |
| {color:green}+1{color} | checkstyle |   5m 34s | There were no new checkstyle issues. |
| {color:green}+1{color} | install |   1m 34s | mvn install still works. |
| {color:green}+1{color} | eclipse:eclipse |   0m 33s | The patch built with eclipse:eclipse.
|
| {color:green}+1{color} | findbugs |   3m 31s | The patch does not introduce any new Findbugs
(version 2.0.3) warnings. |
| {color:green}+1{color} | yarn tests |   1m 57s | Tests passed in hadoop-yarn-common. |
| {color:green}+1{color} | yarn tests |   0m 24s | Tests passed in hadoop-yarn-server-common.
|
| {color:red}-1{color} | yarn tests |  52m  8s | Tests failed in hadoop-yarn-server-resourcemanager.
|
| | |  97m 53s | |
\\
\\
|| Reason || Tests ||
| Failed unit tests | hadoop.yarn.server.resourcemanager.applicationsmanager.TestAMRestart
|
|   | hadoop.yarn.server.resourcemanager.TestRMRestart |
\\
\\
|| Subsystem || Report/Notes ||
| Patch URL | http://issues.apache.org/jira/secure/attachment/12727884/YARN-2123-003.patch
|
| Optional Tests | javadoc javac unit findbugs checkstyle |
| git revision | trunk / c8d7290 |
| hadoop-yarn-common test log | https://builds.apache.org/job/PreCommit-YARN-Build/7492/artifact/patchprocess/testrun_hadoop-yarn-common.txt
|
| hadoop-yarn-server-common test log | https://builds.apache.org/job/PreCommit-YARN-Build/7492/artifact/patchprocess/testrun_hadoop-yarn-server-common.txt
|
| hadoop-yarn-server-resourcemanager test log | https://builds.apache.org/job/PreCommit-YARN-Build/7492/artifact/patchprocess/testrun_hadoop-yarn-server-resourcemanager.txt
|
| Test Results | https://builds.apache.org/job/PreCommit-YARN-Build/7492/testReport/ |
| Console output | https://builds.apache.org/job/PreCommit-YARN-Build/7492/console |


This message was automatically generated.

> Progress bars in Web UI always at 100% due to non-US locale
> -----------------------------------------------------------
>
>                 Key: YARN-2123
>                 URL: https://issues.apache.org/jira/browse/YARN-2123
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: webapp
>    Affects Versions: 2.3.0
>            Reporter: Johannes Simon
>            Assignee: Akira AJISAKA
>         Attachments: YARN-2123-001.patch, YARN-2123-002.patch, YARN-2123-003.patch, screenshot-noPatch.png,
screenshot-patch.png, screenshot.png
>
>
> In our cluster setup, the YARN web UI always shows progress bars at 100% (see screenshot,
progress of the reduce step is roughly at 32.82%). I opened the HTML source code to check
(also see screenshot), and it seems the problem is that it uses a comma as decimal mark, where
most browsers expect a dot for floating-point numbers. This could possibly be due to localized
number formatting being used in the wrong place, which would also explain why this bug is
not always visible.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message