hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kendall Thrapp (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-3143) RM Apps REST API can return NPE or entries missing id and other fields
Date Wed, 04 Feb 2015 22:52:34 GMT

     [ https://issues.apache.org/jira/browse/YARN-3143?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kendall Thrapp updated YARN-3143:
---------------------------------
    Description: 
I'm seeing intermittent null pointer exceptions being returned by
the YARN Apps REST API.

For example:
{code}
http://{cluster}:{port}/ws/v1/cluster/apps?finalStatus=UNDEFINED
{code}

JSON Response was:
{code}
{"RemoteException":{"exception":"NullPointerException","javaClassName":"java.lang.NullPointerException"}}
{code}

At a glance appears to be only when we query for unfinished apps (i.e. finalStatus=UNDEFINED).
 

Possibly related, when I do get back a list of apps, sometimes one or more of the apps will
be missing most of the fields, like id, name, user, etc., and the fields that are present
all have zero for the value.  

For example:
{code}
{"progress":0.0,"clusterId":0,"applicationTags":"","startedTime":0,"finishedTime":0,"elapsedTime":0,"allocatedMB":0,"allocatedVCores":0,"runningContainers":0,"preemptedResourceMB":0,"preemptedResourceVCores":0,"numNonAMContainerPreempted":0,"numAMContainerPreempted":0}
{code}

Let me know if there's any other information I can provide to help debug.

  was:
I'm seeing intermittent null pointer exceptions being returned by
the YARN Apps REST API.

For example:
http://{cluster}:{port}/ws/v1/cluster/apps?finalStatus=UNDEFINED

JSON Response was:
{"RemoteException":{"exception":"NullPointerException","javaClassName":"java.lang.NullPointerException"}}

At a glance appears to be only when we query for unfinished apps (i.e. finalStatus=UNDEFINED).
 

Possibly related, when I do get back a list of apps, sometimes one or more of the apps will
be missing most of the fields, like id, name, user, etc., and the fields that are present
all have zero for the value.  

For example:
{"progress":0.0,"clusterId":0,"applicationTags":"","startedTime":0,"finishedTime":0,"elapsedTime":0,"allocatedMB":0,"allocatedVCores":0,"runningContainers":0,"preemptedResourceMB":0,"preemptedResourceVCores":0,"numNonAMContainerPreempted":0,"numAMContainerPreempted":0}

Let me know if there's any other information I can provide to help debug.


> RM Apps REST API can return NPE or entries missing id and other fields
> ----------------------------------------------------------------------
>
>                 Key: YARN-3143
>                 URL: https://issues.apache.org/jira/browse/YARN-3143
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: webapp
>    Affects Versions: 2.5.2
>            Reporter: Kendall Thrapp
>
> I'm seeing intermittent null pointer exceptions being returned by
> the YARN Apps REST API.
> For example:
> {code}
> http://{cluster}:{port}/ws/v1/cluster/apps?finalStatus=UNDEFINED
> {code}
> JSON Response was:
> {code}
> {"RemoteException":{"exception":"NullPointerException","javaClassName":"java.lang.NullPointerException"}}
> {code}
> At a glance appears to be only when we query for unfinished apps (i.e. finalStatus=UNDEFINED).
 
> Possibly related, when I do get back a list of apps, sometimes one or more of the apps
will be missing most of the fields, like id, name, user, etc., and the fields that are present
all have zero for the value.  
> For example:
> {code}
> {"progress":0.0,"clusterId":0,"applicationTags":"","startedTime":0,"finishedTime":0,"elapsedTime":0,"allocatedMB":0,"allocatedVCores":0,"runningContainers":0,"preemptedResourceMB":0,"preemptedResourceVCores":0,"numNonAMContainerPreempted":0,"numAMContainerPreempted":0}
> {code}
> Let me know if there's any other information I can provide to help debug.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message