hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-3122) Metrics for container's actual CPU usage
Date Tue, 24 Feb 2015 20:51:06 GMT

    [ https://issues.apache.org/jira/browse/YARN-3122?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14335424#comment-14335424

Karthik Kambatla commented on YARN-3122:

Thanks for working on this, Anubhav. The overall structure looks good, but for one concern
on the API. More comments below. I am yet to take a closer look at the tests. 

# ContainerMetrics
## Change phyCpuUsagePercent to pCpuUsagePercent for consistency with other variables? 
## Also, given YARN-3022 hasn't gone into a release yet, can we update the variables introduced
there to reflect units as well - e.g. pMemUsageMBs instead of pMemUsage, and pMemLimitMBs
instead of pMemLimitMbs?
## Change "Vcore usage stats times 1000" to "1000 times vcore usage"? 
# ContainersMonitorImpl: Nit - can we avoid starting lines with parentheses for method arguments?
I am okay with not addressing this, just a personal preference.
# CpuTimeTracker
## Mark as Private-Unstable 
## Nit: Can we update the comments’ location for variables for better readability? 
public static final int UNAVAILABLE = -1;

// CPU used time since system is on (in milliseconds)
BigInteger cumulativeCpuTime = BigInteger.ZERO;

// … 
## Passing along the number of processors in getCpuTrackerUsage doesn’t seem right. If this
is set once for CpuTracker, can we pass it through constructor? 
# ProcfsBasedProcessTree
## Would like to avoid passing numProcessors in getCpuUsagePercent
## The main method only captures the CPU usage, while the class tracks both memory and CPU.
Can we move this to either a test or a util class? 
# NodeManagerHardwareUtils - s/thats/that is/

> Metrics for container's actual CPU usage
> ----------------------------------------
>                 Key: YARN-3122
>                 URL: https://issues.apache.org/jira/browse/YARN-3122
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: nodemanager
>    Affects Versions: 2.6.0
>            Reporter: Anubhav Dhoot
>            Assignee: Anubhav Dhoot
>         Attachments: YARN-3122.001.patch, YARN-3122.002.patch, YARN-3122.prelim.patch,
> It would be nice to capture resource usage per container, for a variety of reasons. This
JIRA is to track CPU usage. 
> YARN-2965 tracks the resource usage on the node, and the two implementations should reuse
code as much as possible. 

This message was sent by Atlassian JIRA

View raw message