hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-3028) Better syntax for replace label CLI
Date Thu, 22 Jan 2015 21:48:36 GMT

    [ https://issues.apache.org/jira/browse/YARN-3028?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14288273#comment-14288273

Wangda Tan commented on YARN-3028:

I see, just re-reviewed, my bad. Yes, 1#/2# are all addressed. 

A nit for test:
I suggest to merge {{testReplaceLabelsOnNodeWithPort}} to {{testReplaceLabelsOnNode}}. It's
no need to split them.
And a case for "=" but without port should added.

Nit for help message:
1) port should be "optional", you can make a small change here for help message:
\[node1:port=label1,label2 node2:port=label1,label2\] should be \[node1\[:port\]=label1...\]

2) {{printHelp}} should be updated as well.

Also, I still suggest add a small comment before
      String[] splits = nodeToLabels.split("=");
To explicitly indicate we support "," for compatibility.


> Better syntax for replace label CLI
> -----------------------------------
>                 Key: YARN-3028
>                 URL: https://issues.apache.org/jira/browse/YARN-3028
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: api, client, resourcemanager
>            Reporter: Jian He
>            Assignee: Rohith
>         Attachments: 0001-YARN-3028.patch
> The command to replace label now is such:
> {code}
> yarn rmadmin -replaceLabelsOnNode [node1:port,label1,label2 node2:port,label1,label2]
> {code}
> Instead of {code} node1:port,label1,label2 {code} I think it's better to say {code} node1:port=label1,label2

This message was sent by Atlassian JIRA

View raw message