hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-3028) Better syntax for replace label CLI
Date Wed, 21 Jan 2015 22:31:40 GMT

    [ https://issues.apache.org/jira/browse/YARN-3028?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14286441#comment-14286441
] 

Wangda Tan commented on YARN-3028:
----------------------------------

Hi [~rohithsharma],
Thanks for working on this. Took a quick look at this patch, One major comment is: I think
we should support "," as well, otherwise this will be a incompatible change.

I suggest to leave tests for "," and "=", and add a small comment in both code and help message
indicate that we suggest user using "=" instead of "," because it will be more clear.

Make sense? Feel free to let me know your thoughts.

Thanks,

> Better syntax for replace label CLI
> -----------------------------------
>
>                 Key: YARN-3028
>                 URL: https://issues.apache.org/jira/browse/YARN-3028
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: api, client, resourcemanager
>            Reporter: Jian He
>            Assignee: Rohith
>         Attachments: 0001-YARN-3028.patch
>
>
> The command to replace label now is such:
> {code}
> yarn rmadmin -replaceLabelsOnNode [node1:port,label1,label2 node2:port,label1,label2]
> {code}
> Instead of {code} node1:port,label1,label2 {code} I think it's better to say {code} node1:port=label1,label2
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message