hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2996) Refine fs operations in FileSystemRMStateStore and few fixes
Date Fri, 09 Jan 2015 11:32:37 GMT

    [ https://issues.apache.org/jira/browse/YARN-2996?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14270907#comment-14270907
] 

Hudson commented on YARN-2996:
------------------------------

FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #68 (See [https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/68/])
YARN-2996. Improved synchronization and I/O operations of FS- and Mem- RMStateStore. Contributed
by Yi Liu. (zjshen: rev dc2eaa26b20cfbbcdd5784bb8761d08a42f29605)
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/recovery/MemoryRMStateStore.java
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/recovery/FileSystemRMStateStore.java
* hadoop-yarn-project/CHANGES.txt


> Refine fs operations in FileSystemRMStateStore and few fixes
> ------------------------------------------------------------
>
>                 Key: YARN-2996
>                 URL: https://issues.apache.org/jira/browse/YARN-2996
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>            Reporter: Yi Liu
>            Assignee: Yi Liu
>             Fix For: 2.7.0
>
>         Attachments: YARN-2996.001.patch, YARN-2996.002.patch, YARN-2996.003.patch, YARN-2996.004.patch
>
>
> In {{FileSystemRMStateStore}}, we can refine some fs operations to improve performance:
> *1.* There are several places invoke {{fs.exists}}, then {{fs.getFileStatus}}, we can
merge them to save one RPC call
> {code}
> if (fs.exists(versionNodePath)) {
>     FileStatus status = fs.getFileStatus(versionNodePath);
> {code}
> *2.*
> {code}
> protected void updateFile(Path outputPath, byte[] data) throws Exception {
>   Path newPath = new Path(outputPath.getParent(), outputPath.getName() + ".new");
>   // use writeFile to make sure .new file is created atomically
>   writeFile(newPath, data);
>   replaceFile(newPath, outputPath);
> }
> {code}
> The {{updateFile}} is not good too, it write file to _output\_file_.tmp, then rename
to _output\_file_.new, then rename it to _output\_file_, we can reduce one rename operation.
> Also there is one unnecessary import, we can remove it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message