hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yi Liu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-2996) Refine fs operations in FileSystemRMStateStore and few fixes
Date Thu, 08 Jan 2015 00:27:35 GMT

     [ https://issues.apache.org/jira/browse/YARN-2996?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Yi Liu updated YARN-2996:
-------------------------
    Summary: Refine fs operations in FileSystemRMStateStore and few fixes  (was: Refine some
fs operations in FileSystemRMStateStore to improve performance)

> Refine fs operations in FileSystemRMStateStore and few fixes
> ------------------------------------------------------------
>
>                 Key: YARN-2996
>                 URL: https://issues.apache.org/jira/browse/YARN-2996
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>            Reporter: Yi Liu
>            Assignee: Yi Liu
>         Attachments: YARN-2996.001.patch, YARN-2996.002.patch, YARN-2996.003.patch, YARN-2996.004.patch
>
>
> In {{FileSystemRMStateStore}}, we can refine some fs operations to improve performance:
> *1.* There are several places invoke {{fs.exists}}, then {{fs.getFileStatus}}, we can
merge them to save one RPC call
> {code}
> if (fs.exists(versionNodePath)) {
>     FileStatus status = fs.getFileStatus(versionNodePath);
> {code}
> *2.*
> {code}
> protected void updateFile(Path outputPath, byte[] data) throws Exception {
>   Path newPath = new Path(outputPath.getParent(), outputPath.getName() + ".new");
>   // use writeFile to make sure .new file is created atomically
>   writeFile(newPath, data);
>   replaceFile(newPath, outputPath);
> }
> {code}
> The {{updateFile}} is not good too, it write file to _output\_file_.tmp, then rename
to _output\_file_.new, then rename it to _output\_file_, we can reduce one rename operation.
> Also there is one unnecessary import, we can remove it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message