hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yi Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2996) Refine some fs operations in FileSystemRMStateStore to improve performance
Date Tue, 06 Jan 2015 05:22:35 GMT

    [ https://issues.apache.org/jira/browse/YARN-2996?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14265707#comment-14265707

Yi Liu commented on YARN-2996:

Thanks [~zjshen] for review.
You are right, for *.new* and *.tmp* file, the existing code uses them for some check. But
actually the incompatible issue you mentioned is really rare and it's not a big issue. {{checkAndResumeUpdateOperation}}
exists because we write state to *.tmp* file, then rename it to *.new* file, and finally rename
to _output\_file_. If we remove step of renaming to *.new* file, we can remove this function
Anyway, I will revert this modification.

So in the new patch, I only keep the #1 described in description. I add two new fixes in the
new patch:
*1.* we missed *synchronized* for {{updateRMDelegationTokenState}}
*2.* Add fix of YARN-3004 to this patch, since {{MemoryRMStateStore}} is only used in test
and we can fix them in this patch too.

> Refine some fs operations in FileSystemRMStateStore to improve performance
> --------------------------------------------------------------------------
>                 Key: YARN-2996
>                 URL: https://issues.apache.org/jira/browse/YARN-2996
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>            Reporter: Yi Liu
>            Assignee: Yi Liu
>         Attachments: YARN-2996.001.patch
> In {{FileSystemRMStateStore}}, we can refine some fs operations to improve performance:
> *1.* There are several places invoke {{fs.exists}}, then {{fs.getFileStatus}}, we can
merge them to save one RPC call
> {code}
> if (fs.exists(versionNodePath)) {
>     FileStatus status = fs.getFileStatus(versionNodePath);
> {code}
> *2.*
> {code}
> protected void updateFile(Path outputPath, byte[] data) throws Exception {
>   Path newPath = new Path(outputPath.getParent(), outputPath.getName() + ".new");
>   // use writeFile to make sure .new file is created atomically
>   writeFile(newPath, data);
>   replaceFile(newPath, outputPath);
> }
> {code}
> The {{updateFile}} is not good too, it write file to _output\_file_.tmp, then rename
to _output\_file_.new, then rename it to _output\_file_, we can reduce one rename operation.
> Also there is one unnecessary import, we can remove it.

This message was sent by Atlassian JIRA

View raw message