hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2868) Add metric for initial container launch time
Date Mon, 12 Jan 2015 23:03:36 GMT

    [ https://issues.apache.org/jira/browse/YARN-2868?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14274363#comment-14274363
] 

Wangda Tan commented on YARN-2868:
----------------------------------

Thanks for explanation, #3 and [~kasha]'s comment make sense to me.

I would prefer to rename following fields for better accuracy:
1) Rename {{allocationRequestStart}} to {{firstAllocationRequestSentTime}} (I misunderstood
in my last comment)
2) Rename {{firstContainerAllocation}} to {{firstContainerAllocatedTime}}

And rename setAllocationRequestStart to "trySet.."(or other better name), what it tries to
do is just trying to do the set.
Return boolean for setAllocationRequestStart make two methods consistent. Future caller may
need it.

Thoughts?

> Add metric for initial container launch time
> --------------------------------------------
>
>                 Key: YARN-2868
>                 URL: https://issues.apache.org/jira/browse/YARN-2868
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Ray Chiang
>            Assignee: Ray Chiang
>              Labels: metrics, supportability
>         Attachments: YARN-2868-01.patch, YARN-2868.002.patch, YARN-2868.003.patch, YARN-2868.004.patch,
YARN-2868.005.patch
>
>
> Add a metric to measure the latency between "starting container allocation" and "first
container actually allocated".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message