hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2996) Refine some fs operations in FileSystemRMStateStore to improve performance
Date Tue, 30 Dec 2014 07:47:13 GMT

    [ https://issues.apache.org/jira/browse/YARN-2996?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14260891#comment-14260891

Hadoop QA commented on YARN-2996:

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  against trunk revision 249cc90.

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include any new or modified
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 javadoc{color}.  There were no new javadoc warning messages.

    {color:green}+1 eclipse:eclipse{color}.  The patch built with eclipse:eclipse.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
2.0.3) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:red}-1 core tests{color}.  The patch failed these unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager:


Test results: https://builds.apache.org/job/PreCommit-YARN-Build/6213//testReport/
Console output: https://builds.apache.org/job/PreCommit-YARN-Build/6213//console

This message is automatically generated.

> Refine some fs operations in FileSystemRMStateStore to improve performance
> --------------------------------------------------------------------------
>                 Key: YARN-2996
>                 URL: https://issues.apache.org/jira/browse/YARN-2996
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>            Reporter: Yi Liu
>            Assignee: Yi Liu
>         Attachments: YARN-2996.001.patch
> In {{FileSystemRMStateStore}}, we can refine some fs operations to improve performance:
> *1.* There are several places invoke {{fs.exists}}, then {{fs.getFileStatus}}, we can
merge them to save one RPC call
> {code}
> if (fs.exists(versionNodePath)) {
>     FileStatus status = fs.getFileStatus(versionNodePath);
> {code}
> *2.*
> {code}
> protected void updateFile(Path outputPath, byte[] data) throws Exception {
>   Path newPath = new Path(outputPath.getParent(), outputPath.getName() + ".new");
>   // use writeFile to make sure .new file is created atomically
>   writeFile(newPath, data);
>   replaceFile(newPath, outputPath);
> }
> {code}
> The {{updateFile}} is not good too, it write file to _output\_file_.tmp, then rename
to _output\_file_.new, then rename it to _output\_file_, we can reduce one rename operation.
> Also there is one unnecessary import, we can remove it.

This message was sent by Atlassian JIRA

View raw message