hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhijie Shen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2952) Incorrect version check in RMStateStore
Date Fri, 12 Dec 2014 17:39:14 GMT

    [ https://issues.apache.org/jira/browse/YARN-2952?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14244491#comment-14244491
] 

Zhijie Shen commented on YARN-2952:
-----------------------------------

This problematic code has be propagated to multiple places where leveldb is used, which need
to be fixed together.

> Incorrect version check in RMStateStore
> ---------------------------------------
>
>                 Key: YARN-2952
>                 URL: https://issues.apache.org/jira/browse/YARN-2952
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Jian He
>            Assignee: Rohith
>
> In RMStateStore#checkVersion:  if we modify  tCURRENT_VERSION_INFO to 2.0, it'll still
store the version as 1.0 which is incorrect; The same thing might happen to NM store, timeline
store.
> {code}
>     // if there is no version info, treat it as 1.0;
>     if (loadedVersion == null) {
>       loadedVersion = Version.newInstance(1, 0);
>     }
>     if (loadedVersion.isCompatibleTo(getCurrentVersion())) {
>       LOG.info("Storing RM state version info " + getCurrentVersion());
>       storeVersion();
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message