hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2819) NPE in ATS Timeline Domains when upgrading from 2.4 to 2.6
Date Sat, 08 Nov 2014 11:43:38 GMT

    [ https://issues.apache.org/jira/browse/YARN-2819?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14203395#comment-14203395
] 

Hudson commented on YARN-2819:
------------------------------

FAILURE: Integrated in Hadoop-Yarn-trunk #737 (See [https://builds.apache.org/job/Hadoop-Yarn-trunk/737/])
YARN-2819. NPE in ATS Timeline Domains when upgrading from 2.4 to 2.6. Contributed by Zhijie
Shen (xgong: rev 4a114dd67aae83e5bb2d65470166de954acf36a2)
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice/src/main/java/org/apache/hadoop/yarn/server/timeline/TimelineDataManager.java
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice/src/test/java/org/apache/hadoop/yarn/server/timeline/TimelineStoreTestUtils.java
* hadoop-yarn-project/CHANGES.txt
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice/src/main/java/org/apache/hadoop/yarn/server/timeline/LeveldbTimelineStore.java
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice/src/test/java/org/apache/hadoop/yarn/server/timeline/TestLeveldbTimelineStore.java
* hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice/src/test/java/org/apache/hadoop/yarn/server/timeline/TestTimelineDataManager.java


> NPE in ATS Timeline Domains when upgrading from 2.4 to 2.6
> ----------------------------------------------------------
>
>                 Key: YARN-2819
>                 URL: https://issues.apache.org/jira/browse/YARN-2819
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: timelineserver
>    Affects Versions: 2.6.0
>            Reporter: Gopal V
>            Assignee: Zhijie Shen
>            Priority: Critical
>              Labels: Upgrade
>             Fix For: 2.6.0
>
>         Attachments: YARN-2819.1.patch
>
>
> {code}
> Caused by: java.lang.NullPointerException
>         at java.lang.String.<init>(String.java:554)
>         at org.apache.hadoop.yarn.server.timeline.LeveldbTimelineStore.put(LeveldbTimelineStore.java:873)
>         at org.apache.hadoop.yarn.server.timeline.LeveldbTimelineStore.put(LeveldbTimelineStore.java:1014)
>         at org.apache.hadoop.yarn.server.timeline.TimelineDataManager.postEntities(TimelineDataManager.java:330)
>         at org.apache.hadoop.yarn.server.timeline.webapp.TimelineWebServices.postEntities(TimelineWebServices.java:260)
> {code}
> triggered by 
> {code}
> entity.getRelatedEntities();
> ...
>             } else {
>               byte[] domainIdBytes = db.get(createDomainIdKey(
>                   relatedEntityId, relatedEntityType, relatedEntityStartTime));
>               // This is the existing entity
>               String domainId = new String(domainIdBytes);
>               if (!domainId.equals(entity.getDomainId())) {
> {code}
> The new String(domainIdBytes); throws an NPE.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message