hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhijie Shen (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-2771) DistributedShell's DSConstants are badly named
Date Thu, 30 Oct 2014 18:55:35 GMT

     [ https://issues.apache.org/jira/browse/YARN-2771?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Zhijie Shen updated YARN-2771:
------------------------------
    Attachment: YARN-2771.2.patch

Just realized I've missed one suggestion from Vinod in the description. I think it makes sense
to keep the old constants, and mark them deprecated. In addition. I altered the logic in the
AM to accept both new and old evn vars.

> DistributedShell's DSConstants are badly named
> ----------------------------------------------
>
>                 Key: YARN-2771
>                 URL: https://issues.apache.org/jira/browse/YARN-2771
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: applications/distributed-shell
>            Reporter: Vinod Kumar Vavilapalli
>            Assignee: Zhijie Shen
>         Attachments: YARN-2771.1.patch, YARN-2771.2.patch
>
>
> I'd rather have underscores (DISTRIBUTED_SHELL_TIMELINE_DOMAIN instead of DISTRIBUTEDSHELLTIMELINEDOMAIN).
> DISTRIBUTEDSHELLTIMELINEDOMAIN is added in this release, can we rename it to be DISTRIBUTED_SHELL_TIMELINE_DOMAIN?
> For the old envs, we can just add new envs that point to the old-one and deprecate the
old ones.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message