hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhijie Shen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2771) DistributedShell's DSConstants are badly named
Date Thu, 30 Oct 2014 17:30:34 GMT

    [ https://issues.apache.org/jira/browse/YARN-2771?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14190430#comment-14190430
] 

Zhijie Shen commented on YARN-2771:
-----------------------------------

Constant name changes. No need for test case.

> DistributedShell's DSConstants are badly named
> ----------------------------------------------
>
>                 Key: YARN-2771
>                 URL: https://issues.apache.org/jira/browse/YARN-2771
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: applications/distributed-shell
>            Reporter: Vinod Kumar Vavilapalli
>            Assignee: Zhijie Shen
>         Attachments: YARN-2771.1.patch
>
>
> I'd rather have underscores (DISTRIBUTED_SHELL_TIMELINE_DOMAIN instead of DISTRIBUTEDSHELLTIMELINEDOMAIN).
> DISTRIBUTEDSHELLTIMELINEDOMAIN is added in this release, can we rename it to be DISTRIBUTED_SHELL_TIMELINE_DOMAIN?
> For the old envs, we can just add new envs that point to the old-one and deprecate the
old ones.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message