hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2690) Make ReservationSystem and its dependent classes independent of Scheduler type
Date Wed, 29 Oct 2014 18:24:34 GMT

    [ https://issues.apache.org/jira/browse/YARN-2690?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14188739#comment-14188739
] 

Karthik Kambatla commented on YARN-2690:
----------------------------------------

Looks mostly good. Can we look into the javadoc warnings? 

Few minor comments:
# Rename ReservationSchedulerConfiguration to ReservationConfiguration? Not sure the Scheduler
in there is adding much information. 
# Make ReservationConfiguration an abstract class that extends Configuration instead of an
interface, so it can implement some of the getters at least those for which it carries defaults.
# Nit: The time defaults should be product of numbers instead of the result. e.g. {{24 * 60
* 60 * 1000}} instead of 86400000L. 



> Make ReservationSystem and its dependent classes independent of Scheduler type  
> --------------------------------------------------------------------------------
>
>                 Key: YARN-2690
>                 URL: https://issues.apache.org/jira/browse/YARN-2690
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: fairscheduler
>            Reporter: Anubhav Dhoot
>            Assignee: Anubhav Dhoot
>         Attachments: YARN-2690.001.patch, YARN-2690.002.patch, YARN-2690.002.patch, YARN-2690.003.patch
>
>
> A lot of common reservation classes depend on CapacityScheduler and specifically its
configuration. This jira is to make them ready for other Schedulers by abstracting out the
configuration.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message