hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2505) [YARN-796] Support get/add/remove/change labels in RM REST API
Date Wed, 17 Sep 2014 07:27:34 GMT

    [ https://issues.apache.org/jira/browse/YARN-2505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14136891#comment-14136891

Wangda Tan commented on YARN-2505:

Hi Craig,
I've reviewed this patch, some comments:
1) I think it's better to rename "/labels/all-nodes-to-labels" to "/labels/nodes-to-labels",
because it's not "all" nodes-to-labels always. 
And I think the filter should be better changed to node-filter. My feeling is it's not very
natural to apply a filter on values instead of keys.
Or we can support both node-filter and label-filter.

2) Some lines exceeds 80 chars, you can run regex on vim to check:

3) Test looks very good to me, thanks!


> [YARN-796] Support get/add/remove/change labels in RM REST API
> --------------------------------------------------------------
>                 Key: YARN-2505
>                 URL: https://issues.apache.org/jira/browse/YARN-2505
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Wangda Tan
>            Assignee: Craig Welch
>         Attachments: YARN-2505.patch

This message was sent by Atlassian JIRA

View raw message