hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wangda Tan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2505) [YARN-796] Support get/add/remove/change labels in RM REST API
Date Tue, 23 Sep 2014 07:47:35 GMT

    [ https://issues.apache.org/jira/browse/YARN-2505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14144520#comment-14144520

Wangda Tan commented on YARN-2505:

Thanks for update. However, I just compared two patches, it seems the new one is double-sized
of the old one.

bq. -re rename all-nodes-to-lables to nodes-to-labels - done
I found in the patch is still
+  @GET
+  @Path("/labels/all-nodes-to-labels")
I guess you uploaded a wrong patch here.

bq. -re node-filter
I mis-understood the label filter before, it makes sense to me. Currently, REST will only
return intersection set of labels on the nodes of the label filter passed in. But I think
it may be also a valid use case when a user doesn't want to get whole set when intersection
set is non-empty. For example, user want to query nodes contains label=GPU, and full sets
of label returned can help user understand what else label contains in returned nodes. Are
they in linux or windows platform, etc.
So I propose to add an "do-intersection" (or some other name) parameter here, I think by default
it can be either true/false, but user can have chance to set it.

According to the comment: https://issues.apache.org/jira/browse/YARN-2494?focusedCommentId=14144501&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14144501.

Do you think we need change add/remove labels to add/remove node labels?


> [YARN-796] Support get/add/remove/change labels in RM REST API
> --------------------------------------------------------------
>                 Key: YARN-2505
>                 URL: https://issues.apache.org/jira/browse/YARN-2505
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Wangda Tan
>            Assignee: Craig Welch
>         Attachments: YARN-2505.1.patch, YARN-2505.patch

This message was sent by Atlassian JIRA

View raw message