hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jian He (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-1707) Making the CapacityScheduler more dynamic
Date Wed, 03 Sep 2014 21:13:55 GMT

    [ https://issues.apache.org/jira/browse/YARN-1707?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14120467#comment-14120467
] 

Jian He commented on YARN-1707:
-------------------------------


- rename dyQConf/sesConf to entitleMent
{code}
 setEntitlement(String queue, QueueEntitlement dyQConf)

  public synchronized void setEntitlement(String inQueue,
      QueueEntitlement sesConf) throws SchedulerConfigEditException,
{code}

- should userLimit be reinitialized in ReservationQueue/PlanQueue as well ? 
{code}
    setUserLimit(parent.getUserLimitForReservation());
    setUserLimitFactor(parent.getUserLimitFactor());
{code}
-  I think the newlyParsedParentQueue doesn't have the updated value at this point?
{code}
    this.maxAppsForReservation = newlyParsedParentQueue.maxAppsForReservation;
    this.maxAppsPerUserForReservation =
        newlyParsedParentQueue.maxAppsPerUserForReservation;
{code}
- indentation format
{code}
      } else {
      queue = 
          new LeafQueue(csContext, queueName, parent,oldQueues.get(queueName));
      
      // Used only for unit tests
      queue = hook.hook(queue);
      }
{code}
- SchedulerConfigEditException, a better name ? this exception is used in multiple scenarios.
- PlanQueue#showReservationsAsQueues / showReservationsAsLeafs, make boolean flag name and
method name consistent


> Making the CapacityScheduler more dynamic
> -----------------------------------------
>
>                 Key: YARN-1707
>                 URL: https://issues.apache.org/jira/browse/YARN-1707
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler
>            Reporter: Carlo Curino
>            Assignee: Carlo Curino
>              Labels: capacity-scheduler
>         Attachments: YARN-1707.2.patch, YARN-1707.3.patch, YARN-1707.4.patch, YARN-1707.5.patch,
YARN-1707.6.patch, YARN-1707.patch
>
>
> The CapacityScheduler is a rather static at the moment, and refreshqueue provides a rather
heavy-handed way to reconfigure it. Moving towards long-running services (tracked in YARN-896)
and to enable more advanced admission control and resource parcelling we need to make the
CapacityScheduler more dynamic. This is instrumental to the umbrella jira YARN-1051.
> Concretely this require the following changes:
> * create queues dynamically
> * destroy queues dynamically
> * dynamically change queue parameters (e.g., capacity) 
> * modify refreshqueue validation to enforce sum(child.getCapacity())<= 100% instead
of ==100%
> We limit this to LeafQueues. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message