hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-2424) LCE should support non-cgroups, non-secure mode
Date Sat, 16 Aug 2014 17:54:18 GMT

     [ https://issues.apache.org/jira/browse/YARN-2424?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Allen Wittenauer updated YARN-2424:
-----------------------------------

    Attachment: YARN-2424.patch

This adds a yarn configuration boolean called yarn.nodemanager.linux-container-executor.nonsecure-mode.limit-users
that when set to true keeps the current behavior but when set to false goes back to the previous,
non-regressed behavior.

> LCE should support non-cgroups, non-secure mode
> -----------------------------------------------
>
>                 Key: YARN-2424
>                 URL: https://issues.apache.org/jira/browse/YARN-2424
>             Project: Hadoop YARN
>          Issue Type: Bug
>          Components: nodemanager
>    Affects Versions: 2.3.0, 2.4.0, 2.5.0, 2.4.1
>            Reporter: Allen Wittenauer
>            Priority: Blocker
>              Labels: regression
>         Attachments: YARN-2424.patch
>
>
> After YARN-1253, LCE no longer works for non-secure, non-cgroup scenarios.  This is a
fairly serious regression, as turning on LCE prior to turning on full-blown security is a
fairly standard procedure.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message