hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhijie Shen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2347) Consolidate RMStateVersion and NMDBSchemaVersion into StateVersion in yarn-server-common
Date Sun, 27 Jul 2014 02:18:38 GMT

    [ https://issues.apache.org/jira/browse/YARN-2347?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14075529#comment-14075529

Zhijie Shen commented on YARN-2347:

bq. Actually, this version get used for RMState, NMState, ShuffleHandler's State, etc. In
this case, may not sounds so weird to you?

IMHO, the version belongs to the stores, but it happens that the stores are storing the state
information. It's more accurate to say the version is of the storage schema. On the other
side, timeline server is a stateless machine, but it will still use this version stack. StateVersion
may make users consider it stateful. If StateVersion is going to be only used for the storage
layer, something like StoreVersion sounds better to me. On the contrary, if it is going to
be used to annotate other stuff, such as RPC interface, it looks good to have more generalized

Anyway, it's not a critical problem, and I'm not strong minded about refatoring the name.
However, it reminds me another issue: it may be better to add some more javadoc for StateVersion
to let users know what it is really about.

> Consolidate RMStateVersion and NMDBSchemaVersion into StateVersion in yarn-server-common
> ----------------------------------------------------------------------------------------
>                 Key: YARN-2347
>                 URL: https://issues.apache.org/jira/browse/YARN-2347
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Junping Du
>            Assignee: Junping Du
>         Attachments: YARN-2347-v2.patch, YARN-2347-v3.patch, YARN-2347.patch
> We have similar things for version state for RM, NM, TS (TimelineServer), etc. I think
we should consolidate them into a common object.

This message was sent by Atlassian JIRA

View raw message