hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kenji Kikushima (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (YARN-2239) Rename ClusterMetrics#getUnhealthyNMs() to getNumUnhealthyNMs()
Date Tue, 01 Jul 2014 07:56:24 GMT

     [ https://issues.apache.org/jira/browse/YARN-2239?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kenji Kikushima updated YARN-2239:
----------------------------------

    Attachment: YARN-2239.patch

Attached a patch.

> Rename ClusterMetrics#getUnhealthyNMs() to getNumUnhealthyNMs()
> ---------------------------------------------------------------
>
>                 Key: YARN-2239
>                 URL: https://issues.apache.org/jira/browse/YARN-2239
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: resourcemanager
>    Affects Versions: 2.4.0
>            Reporter: Kenji Kikushima
>            Assignee: Kenji Kikushima
>            Priority: Trivial
>         Attachments: YARN-2239.patch
>
>
> In ClusterMetrics, other get NMs() methods have "Num" prefix. (Ex. getNumLostNMs()/getNumRebootedNMs())
> For naming consistency, we should rename getUnhealthyNMs() to getNumUnhealthyNMs().



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message