hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kumar Vavilapalli (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2092) Incompatible org.codehaus.jackson* dependencies when moving from 2.4.0 to 2.5.0-SNAPSHOT
Date Tue, 27 May 2014 22:14:05 GMT

    [ https://issues.apache.org/jira/browse/YARN-2092?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14010397#comment-14010397
] 

Vinod Kumar Vavilapalli commented on YARN-2092:
-----------------------------------------------

Okay folks, this is an incompatible change any way we look at it. OSIG/custom classloader
solutions are good, but they don't exist in their entirety today.

bq.  like from the HADOOP-10104 patch. Which went in because the 2.2+ version of jackson was
so out of date is was breaking other things.
[~stevel@apache.org], what are these?

We ran into other application failures downstream that depend on jackson. I propose that we
reopen HADOOP-10104 to revert the patch from branch-2 and leave it on trunk unless there is
a solid answer to the question immediately above.

> Incompatible org.codehaus.jackson* dependencies when moving from 2.4.0 to 2.5.0-SNAPSHOT
> ----------------------------------------------------------------------------------------
>
>                 Key: YARN-2092
>                 URL: https://issues.apache.org/jira/browse/YARN-2092
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Hitesh Shah
>
> Came across this when trying to integrate with the timeline server. Using a 1.8.8 dependency
of jackson works fine against 2.4.0 but fails against 2.5.0-SNAPSHOT which needs 1.9.13. This
is in the scenario where the user jars are first in the classpath.  



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message