hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2092) Incompatible org.codehaus.jackson* dependencies when moving from 2.4.0 to 2.5.0-SNAPSHOT
Date Thu, 22 May 2014 08:24:39 GMT

    [ https://issues.apache.org/jira/browse/YARN-2092?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14005718#comment-14005718
] 

Steve Loughran commented on YARN-2092:
--------------------------------------

This seems like from the HADOOP-10104 patch.  Which went in because the 2.2+ version of jackson
was so out of date is was breaking other things.

I'm not sure its so much incompatible as that TEZ is trying to push in its own version of
jackon, which is then leading to classpath mixing problems. Even if you try to push in one
set of the JARs ahead of the other, things are going to break. I know, I've tried.

jackson 1.x should be compatible at run time with code build for previous versions. If there's
a link problem there then it's something we can take up with the Jackson team. 



> Incompatible org.codehaus.jackson* dependencies when moving from 2.4.0 to 2.5.0-SNAPSHOT
> ----------------------------------------------------------------------------------------
>
>                 Key: YARN-2092
>                 URL: https://issues.apache.org/jira/browse/YARN-2092
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Hitesh Shah
>
> Came across this when trying to integrate with the timeline server. Using a 1.8.8 dependency
of jackson works fine against 2.4.0 but fails against 2.5.0-SNAPSHOT which needs 1.9.13. This
is in the scenario where the user jars are first in the classpath.  



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message