hadoop-yarn-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (YARN-2092) Incompatible org.codehaus.jackson* dependencies when moving from 2.4.0 to 2.5.0-SNAPSHOT
Date Thu, 22 May 2014 10:05:01 GMT

    [ https://issues.apache.org/jira/browse/YARN-2092?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14005804#comment-14005804
] 

Steve Loughran commented on YARN-2092:
--------------------------------------

I should add that the underlying issue is that the AM gets then entire CP from the {{yarn.lib.classpath}}.
That's mandatory to pick up a version of the hadoop binaries (and -site.xml files) compatible
with the rest of the cluster. But it brings in all the other dependencies which hadoop itself
relies on. As hadoop evolves, this problem will only continue.

The only viable long-term solution is to somehow support OSGi-launched AMs, so the AM only
gets the org.apache.hadoop classes from the hadoop JARs, and has to explicitly add everything
itself. See HADOOP-7977 for this -maybe it's something we could target for hadoop 3.0 driven
by the needs of AMs

> Incompatible org.codehaus.jackson* dependencies when moving from 2.4.0 to 2.5.0-SNAPSHOT
> ----------------------------------------------------------------------------------------
>
>                 Key: YARN-2092
>                 URL: https://issues.apache.org/jira/browse/YARN-2092
>             Project: Hadoop YARN
>          Issue Type: Bug
>            Reporter: Hitesh Shah
>
> Came across this when trying to integrate with the timeline server. Using a 1.8.8 dependency
of jackson works fine against 2.4.0 but fails against 2.5.0-SNAPSHOT which needs 1.9.13. This
is in the scenario where the user jars are first in the classpath.  



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message